Incident Type
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 10:41 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 13, 2023 - 14:33 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2023 - 14:33 EST
Identified
At approximately 13:22 EST today, we experienced a service disruption that may have affected a limited number of customers in the North American regions.

The incident's root cause is still under investigation; initial analysis indicates a database performance issue for some requests, bringing the system to an impacting service disruption.

During this time, the web portal may have been slow or unresponsive.
For any questions or concerns, please do not hesitate to contact our customer support team.
Posted Nov 13, 2023 - 14:00 EST
This incident affected: TrackTik (TrackTik US).