Degradation of service found outside of IVR's Network (Europe)
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 13:04 EDT
Update
We are continuing to investigate this issue.
Posted Jun 14, 2022 - 13:03 EDT
Investigating
Numbers calling from Europe may experience issues with IVR. An investigation is currently ongoing.
Posted Jun 09, 2022 - 21:06 EDT
This incident affected: TrackTik Europe and Communications (IVR/Call-in Phone Numbers).