TrackTik Service Disruption
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 18:54 EDT
Investigating
We are currently experiencing a service disruption that may be affecting report PDF generation, data replication and email notifications.

Our Engineering team is working to identify the root cause and implement a solution. Users in the US East may be affected.
Posted Jun 13, 2023 - 15:30 EDT
This incident affected: TrackTik (TrackTik US).