TrackTik Service Disruption
Incident Report for TrackTik
Resolved
Services have been restored.
Posted Aug 17, 2023 - 17:00 EDT
Investigating
We are currently experiencing a service disruption that is affecting users in Canada.

Our engineering teams are working to get services restored as soon as possible.
Posted Aug 17, 2023 - 16:29 EDT
This incident affected: TrackTik (TrackTik Canada).