Issue with our upstream provider
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted Mar 23, 2024 - 20:21 EDT
Investigating
Our upstream provider, Twillio, is currently experiencing an issue that is affecting our ability to send SMS to some customers. We will resolve this incident once we have received confirmation that our upstream provider has resolved the issue.
Posted Mar 22, 2024 - 19:37 EDT
This incident affected: TrackTik (SMS Long Code, North America).