TrackTik Service Disruption
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted Jan 03, 2023 - 15:42 EST
Identified
We are currently experiencing a service disruption.

Our Engineering team is working to identify the root cause and implement a solution. Users in the US East may be affected.

We will send an additional update in 10 minutes.
Posted Jan 03, 2023 - 15:37 EST
This incident affected: TrackTik (TrackTik US).