Latency Issues

Incident Report for TrackTik

Monitoring

Performance has returned to normal levels and service should now be operating as expected. We are continuing to monitor the environment closely to ensure stability, but at this time service levels have returned to normal.
Posted Sep 18, 2026 - 14:18 EDT

Investigating

We are aware of an issue impacting performance for some customers and are actively investigating.

Our team is working to identify the root cause and restore normal performance as quickly as possible. We will provide further updates as more information becomes available.
Posted Sep 18, 2026 - 13:57 EDT
This incident affects: TrackTik (TrackTik Cloud).