Incident Type
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted Sep 16, 2024 - 15:28 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2024 - 14:05 EDT
Identified
At approximately 13:15 EST today, we experienced a service disruption that may have affected a limited number of customers in the North America

The incident root cause is still under investigation; initial analysis indicates a database performance issue for some requests that caused a disruption of service.

During this time, the web portal may have been slow or unresponsive.
For any questions or concerns, please do not hesitate to contact our customer support team.
Posted Sep 16, 2024 - 13:40 EDT
This incident affected: TrackTik (TrackTik US).