The issue impacting the US West instance has been resolved. Some users experienced latency and timeouts due to elevated traffic conditions on Sat. Oct 25 and Sun. Oct. 26., 2025. Mitigation steps were applied, and service performance has returned to normal with no further delays observed.
Thank you for your patience while we worked to restore stability.
Posted Oct 27, 2025 - 08:30 EDT
Monitoring
We have identified the source of the issue impacting the US West instance and have implemented mitigation measures. Our team is now monitoring the service to ensure stability.
Posted Oct 26, 2025 - 21:42 EDT
Investigating
We are currently investigating intermittent connectivity and login issues affecting the US West instance. Some users may experience problems signing in, submitting reports, or conducting tours in the Mobile Guard App and web portal.
Our engineering team is actively working to restore full service.