Americas Infrastructure Disruption

Incident Report for TrackTik

Resolved

Our services are now operating normally.
Posted Dec 16, 2024 - 15:29 EST

Update

We are continuing to investigate this issue.
Posted Dec 16, 2024 - 15:24 EST

Investigating

Customers on US West infrastructure may experience problems loading their portals. We are currently investigating the issue.
Posted Dec 16, 2024 - 15:22 EST
This incident affected: TrackTik (TrackTik US, TrackTik Canada).