AWS has resolved the outage and reports all services are back to normal. Any temporary effects on TrackTik services should now be resolved
Posted Oct 20, 2025 - 22:49 EDT
Update
TrackTik customers may experience limited effects from the ongoing AWS outage. You may also still have delays when trying to reach our team via phone or chat, however, our email and web forms remain unaffected. Our teams are actively monitoring AWS updates and resolution timelines.
Posted Oct 20, 2025 - 18:12 EDT
Monitoring
Our customers may experience limited effects from the ongoing AWS outage. You may also encounter delays when trying to reach our team via call or chat. Our teams are actively monitoring AWS updates and resolution timelines.