The issue affecting report editing has been resolved. Our monitoring indicates that report editing functionality has returned to normal operation, and no further impact is expected at this time.
If you encounter any additional issues with reports, please contact Support with details of the affected user(s), example report(s), and any error messages or unexpected behavior observed so we can investigate promptly.
We apologize for the disruption and thank you for your patience.
Posted Sep 09, 2026 - 17:15 EDT
Monitoring
The hotfix has been deployed and we are currently monitoring the platform to ensure the issue is fully resolved.
Users should now be able to edit reports normally. Our team will continue to closely monitor system performance and validate that report editing remains stable across affected environments.
If you continue to experience issues, please contact Support and provide details of the report and any error messages encountered.
We appreciate your patience while we worked to resolve this issue.
Posted Sep 09, 2026 - 14:34 EDT
Identified
We have identified the root cause of the issue affecting report editing for some clients.
At this time, users may still experience issues when attempting to edit reports while we implement the fix. Our engineering team has developed a hotfix and is currently validating and preparing it for deployment.
We are actively working to restore full functionality as quickly as possible and will provide another update once the hotfix has been deployed.
We apologize for the disruption and appreciate your patience.
Posted Sep 09, 2026 - 13:12 EDT
Investigating
We are aware of reports that some clients are currently unable to edit reports within the platform.
Our team is actively investigating the issue and working to identify the root cause. We will provide further updates as more information becomes available.
We apologize for the inconvenience and appreciate your patience while we work toward a resolution.
Posted Sep 09, 2026 - 13:07 EDT
This incident affected: TrackTik (TrackTik Cloud).