Issue with Multi-Page PDF Previews

Incident Report for TrackTik

Resolved

The issue affecting multi-page PDF previews in the Post Order section is now resolved. Google has fixed the underlying API disruption, and the document viewer is back to normal operation. Thank you for your patience.
Posted Mar 05, 2026 - 15:54 EST

Identified

We have identified the root cause of the PDF preview issue. The document viewer relies on a third-party API provided by Google, which is currently experiencing a service disruption. As this is an external issue, we do not have an immediate ETA for a resolution, but we are monitoring their progress closely.

Please rest assured that your data is safe and all document pages are stored securely in our system.
Posted Mar 05, 2026 - 12:21 EST

Update

At this time, we are still investigating the issue affecting the Post Order section of the application where only the first page of multi-page PDFs is being displayed in the viewer.

Where available, users can download the document directly to their device to view all pages. We are aware that some uses (such as those in the Guard portal) may not have download permissions, and we are working to restore the preview functionality as our highest priority.

No data loss has occurred; all uploaded documents remain complete in our system. Thank you for your patience as we work towards a fix.
Posted Mar 05, 2026 - 11:30 EST

Investigating

We are currently investigating an issue affecting the Post Order section of the application. Some clients have reported that when viewing multi-page PDF documents via the in-app document viewer, only the first page is being displayed. Our team has confirmed that there is no data loss; all uploaded documents remain complete in our system. We are actively investigating the underlying cause, and we will share updates as more information is available.
Posted Mar 05, 2026 - 10:46 EST
This incident affected: TrackTik (Service Delivery).