TrackTik Service Disruption
Incident Report for TrackTik
Resolved
Services have been restored.
Posted Jul 22, 2024 - 15:44 EDT
Investigating
We are currently experiencing a service disruption that is affecting users in North America East.

Our engineering teams are working to get services restored as soon as possible.
Posted Jul 22, 2024 - 15:30 EDT