TrackTik Service Disruption - US-West Region (California)
Incident Report for TrackTik
Resolved
Our Engineering team identified the root cause and resolved the issue.
Posted Mar 22, 2021 - 12:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2021 - 12:03 EDT
Investigating
We are currently experiencing a service disruption in our US-West Region (California). Our Engineering team is working to identify the root cause and implement a solution.
Posted Mar 22, 2021 - 11:40 EDT
This incident affected: TrackTik (TrackTik US).