Portals with EU domain name down

Incident Report for TrackTik

Resolved

The DNS has been successfully propagated across all regions, and the service is functioning normally. If you are still having trouble accessing your portal, consider clearing your browser cache or flushing your computer's DNS. Additionally, restarting your phone may help trigger a refresh.
Posted Nov 21, 2024 - 08:52 EST

Monitoring

DNS propagation is underway, and portals should now be accessible in most, if not all, regions. This delay occurs due to the DNS propagation process, during which DNS information is updated across the internet. The duration of this delay may vary depending on your internet provider. You can try clearing your browser cache or restarting your phone to prompt a refresh.
Posted Nov 21, 2024 - 08:27 EST

Identified

We have identified a significant issue affecting the DNS service for the EU domain. Our team has taken corrective actions, and the service is now in the process of being restored. The restoration will occur gradually across different regions. This means some users may experience normal service sooner than others, depending on how quickly the changes propagate through the global DNS network.
Posted Nov 21, 2024 - 07:43 EST
This incident affected: TrackTik (TrackTik Europe).