TrackTik Service Disruption
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted 5 days ago. Oct 11, 2019 - 13:39 EDT
Monitoring
A fix has been implemented and all services should now be restored
Posted 5 days ago. Oct 11, 2019 - 13:36 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 5 days ago. Oct 11, 2019 - 13:34 EDT
Update
We are continuing to investigate this issue.
Posted 5 days ago. Oct 11, 2019 - 13:23 EDT
Update
We are continuing to investigate this issue.
Posted 5 days ago. Oct 11, 2019 - 13:22 EDT
Update
We are continuing to investigate this issue.
Posted 5 days ago. Oct 11, 2019 - 13:17 EDT
Investigating
We are currently experiencing a service disruption.

Our Engineering team is working to identify the root cause and implement a solution. **Europe/ North American Infrastructure** users may be affected.

We will send an additional update in **15** minutes.
Posted 6 days ago. Oct 11, 2019 - 13:17 EDT
This incident affected: TrackTik US and TrackTik Canada.