Google Maps API Errors
Incident Report for TrackTik
Resolved
This is incident has been resolved.
Posted about 1 year ago. Jul 20, 2018 - 22:37 EDT
Investigating
We're experiencing API errors with our Google Maps integration and are currently looking into the issue.
Portal users may experience an overlay with a "This page can't load Google Maps correctly." error message. You can temporarily dismiss it without loss of functionality.
Posted about 1 year ago. Jul 20, 2018 - 22:19 EDT
This incident affected: TrackTik US, TrackTik Canada, TrackTik Asia, and TrackTik Europe.