Delay in our US email notifications
Incident Report for TrackTik
Resolved
Notifications are now being sent on time. The incident is now closed.
Posted about 1 month ago. Sep 06, 2019 - 16:01 EDT
Monitoring
We are experiencing delays in email notifications and report delivery. Though the problem has been identified and resolved, notifications may arrive late for some time.
Posted about 1 month ago. Sep 06, 2019 - 15:30 EDT
This incident affected: Communications (Email, SMS, IVR) (Email Notifications).