TrackTik Service Disruption - Unexpected Delay in Restoring the Canadian Infrastructure
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted 5 months ago. May 22, 2019 - 10:53 EDT
Investigating
We are currently experiencing a service disruption.
There was an unexpected delay in restoring the Canadian Infrastructure
Our Engineering team is working to identify the root cause and implement a solution.

We will send an additional update in **10** minutes.
Posted 5 months ago. May 22, 2019 - 10:25 EDT
This incident affected: TrackTik Canada.