Trouble logging in
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted over 1 year ago. May 22, 2018 - 18:26 EDT
Investigating
Due to a planned performance upgrade that has increased our server capacity, some users may have experienced trouble when logging onto their client portals between 18:15 EST and 18:19 EST

The issue has since been rectified and we are up and running at optimal service.

If you have any issues or concerns please report it to support.tracktik.com
Posted over 1 year ago. May 22, 2018 - 18:26 EDT
This incident affected: TrackTik US, TrackTik Canada, TrackTik Asia, and TrackTik Europe.