TrackTik Service Disruption
Incident Report for TrackTik
Resolved
The issue was identified and resolved. All connections to client portals have been restored as of 2018-03-20 / 3:27:18 PM
Posted over 1 year ago. Mar 20, 2018 - 15:39 EDT
Investigating
We are currently experiencing a service disruption.
At 2018-03-20 / 3:20:00 PM A connection issue to client portals was identified

Our Engineering team is working to identify the root cause and implement a solution. **Most users may experience a connection error or inability to connect.

We will send an additional update in 30 minutes.
Posted over 1 year ago. Mar 20, 2018 - 15:30 EDT