Issue with Dispatch+
Incident Report for TrackTik
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 20, 2019 - 18:08 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Mar 20, 2019 - 15:31 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 7 months ago. Mar 20, 2019 - 12:27 EDT
Investigating
We're experiencing an issue with the Dispatch+ Module (unable to edit reports in view) and are currently looking into the issue.
Posted 7 months ago. Mar 20, 2019 - 07:39 EDT
This incident affected: TrackTik US, TrackTik Canada, TrackTik Asia, and TrackTik Europe.